Jump to content
SASS Wire Forum

Search the Community

Showing results for tags 'navy arms'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • SASS Wire Questions
    • SASS Wire F.A.Q.
  • SASS Forums
    • SASS Wire
    • SASS Wire Saloon
    • SASS Merchant Corner
    • SASS Wire Classifieds
    • TEAM SASS
  • Event Forums
    • END of TRAIL
    • SASS Events Wire

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests


SASS #


SASS Affiliated Club

Found 1 result

  1. So I picked up a Navy Arms '73 carbine in 44-40 off of gunbroker(1st and probably last time I do that). Well it seems to work just fine until you load it. 1st issue the spring and follower would get stuck in the mag tube. It seemed extremely weak when I loaded it. I had a spare one laying around so easy enough. 2nd issue when you go to chamber a round the 2nd round slides into the carrier far enough that it will not let it lift. I've tried OAL 1.56 thru 1.60 Doesnt matter if you only load 2 shells or 10 it does it every time. I also swapped back to the original spring just to be sure the replacement one wasnt the cause. same thing. Any idea of what the possible causes are? Thanks, T.F. Jack
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.